using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([0-9]{2}\) (?:9[0-9]{1}|[1-5]{1})[0-9]{3}-[0-9]{4}";
string input = @"(11) 33333321
(11) 8543-0897
(11) 99076-1345
(11) 9046 -1345
(11) 2450 -5678
(11) 9764-4356
(11) 99991111
(11) 58753201
(11) 67890431
(11) 999999999
(11) 78906542
(11) 83567031
(11) 09853212
(11) 45678901
(11) 23456790
(11) 4004-1000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}