# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\([0-9]{2}\) (?:9[0-9]{1}|[1-5]{1})[0-9]{3}-[0-9]{4}"
test_str = ("(11) 33333321\n"
"(11) 8543-0897\n"
"(11) 99076-1345\n"
"(11) 9046 -1345\n"
"(11) 2450 -5678\n"
"(11) 9764-4356\n"
"(11) 99991111\n"
"(11) 58753201\n"
"(11) 67890431\n"
"(11) 999999999\n"
"(11) 78906542\n"
"(11) 83567031\n"
"(11) 09853212\n"
"(11) 45678901\n"
"(11) 23456790\n"
"(11) 4004-1000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.