import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\r?\\n:";
final String string = "вопрос 1\n"
+ ":ответ 1\n"
+ "вопрос 2\n"
+ ":ответ2\n"
+ "вопрос 3\n"
+ ":ответ3";
final String subst = ":";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}