const regex = /\r?\n:/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\r?\\n:', 'g')
const str = `вопрос 1
:ответ 1
вопрос 2
:ответ2
вопрос 3
:ответ3`;
const subst = `:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);