$re = '/\r?\n:/';
$str = 'вопрос 1
:ответ 1
вопрос 2
:ответ2
вопрос 3
:ответ3';
$subst = ":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;