package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)li>(.*?)(?:<\/li)`)
var str = `***some text*** li> ***data to capture***</li ***more text***`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}