re = /li>(.*?)(?:<\/li)/m
str = '***some text*** li> ***data to capture***</li ***more text***'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end