$re = '/nt[ {2}]\b/';
$str = 'nt1 nt2 nt2bfsdf nt3 nt4 nt5 xxnt6 xxnt7 nt8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);