// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"nt[ {2}]\b").unwrap();
let string = "nt1 nt2 nt2bfsdf nt3 nt4 nt5 xxnt6 xxnt7 nt8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}