$re = '/(?m)(?<!^)(?<![.?!] )[A-Z][A-Za-z]*/m';
$str = 'Now is the Time.
For all good Rubyists? To come to the aid of their Bowling team. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);