re = /(?m)(?<!^)(?<![.?!] )[A-Z][A-Za-z]*/m
str = 'Now is the Time.
For all good Rubyists? To come to the aid of their Bowling team. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end