# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\S)\s(?=\S)/_/;t' <<< "SYS W$_FIasdfLESTATXS TABLE PARTI
TION 0 "