use strict;
my $str = 'SYS W$_FIasdfLESTATXS TABLE PARTI
TION 0 ';
my $regex = qr/(?<=\S)\s(?=\S)/p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";