using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(text|simple)(?![^<]*>|[^<>]*<\/)";
string substitution = @"<span class='notranslate'>$1</span>";
string input = @"This is simple html text <span class='simple'>simple simple text text</span> text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}