$re = '/(text|simple)(?![^<]*>|[^<>]*<\/)/m';
$str = 'This is simple html text <span class=\'simple\'>simple simple text text</span> text';
$subst = "<span class='notranslate'>$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;