use strict;
my $str = 'This is simple html text <span class=\'simple\'>simple simple text text</span> text';
my $regex = qr/(text|simple)(?![^<]*>|[^<>]*<\/)/mp;
my $subst = '<span class=\'notranslate\'>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";