using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^|[+359]+(-| )[2]\1[\d]{3}\1[\d]{4}\b";
string input = @" +359-2-222-2222, +359/2/222/2222, +359-2 222 2222, +359 2-222-2222, +359-2-222-222, +359-2-222-22222, +359 2 222 2222, +359-2-222-2222";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}