re = /^|[+359]+(-| )[2]\1[\d]{3}\1[\d]{4}\b/
str = ' +359-2-222-2222, +359/2/222/2222, +359-2 222 2222, +359 2-222-2222, +359-2-222-222, +359-2-222-22222, +359 2 222 2222, +359-2-222-2222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end