const regex = /^|[+359]+(-| )[2]\1[\d]{3}\1[\d]{4}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^|[+359]+(-| )[2]\\1[\\d]{3}\\1[\\d]{4}\\b', 'g')
const str = ` +359-2-222-2222, +359/2/222/2222, +359-2 222 2222, +359 2-222-2222, +359-2-222-222, +359-2-222-22222, +359 2 222 2222, +359-2-222-2222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}