# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[img\](.+?)\[\/img\]/<img src=${1}>/;t' <<< "[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]"