import Foundation
let pattern = #"\[img\](.+?)\[/img\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src=${1}>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}