// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[img\](.+?)\[/img\]").unwrap();
let string = "[img]http://df-21.net/phpbb/images/avatars/deathstar.gif[/img][img]http://df-21.net/phpbb/images/avatars/ackbar.gif[/img]";
let substitution = "<img src=${1}>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}