using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(THE\s)?((7)|ESTATE OF\s))?(.*?)(-?\s?DECEASED)?((P\.?R\.? OF THE)?(?(3)|\sESTATE OF))$";
string input = @"SMITH JOHN ESTATE OF
SMITH JOHN J ESTATE OF
SMITH JOHN JAMES ESTATE OF
SMITH, JOHN ESTATE OF
SMITH, JOHN J ESTATE OF
SMITH, JOHN JAMES ESTATE OF
ESTATE OF JOHN SMITH - DECEASED
ESTATE OF JOHN J SMITH - DECEASED
ESTATE OF JOHN JAMES SMITH - DECEASED
SMITH, JOHN DECEASED ESTATE OF
SMITH, JOHN J DECEASED ESTATE OF
SMITH, JOHN JAMES DECEASED ESTATE OF
THE ESTATE OF JOHN SMITH
THE ESTATE OF JOHN J. SMITH
THE ESTATE OF JOHN JAMES SMITH
THE ESTATE OF JOHN J. SMITH, JR.
THE ESTATE OF JOHN SMITH DECEASED
THE ESTATE OF JOHN J. SMITH DECEASED
THE ESTATE OF JOHN JAMES SMITH DECEASED
THE ESTATE OF JOHN J. SMITH, JR. DECEASED
SMITH, JOHN, P.R. OF THE ESTATE OF
SMITH, JOHN, J, P.R. OF THE ESTATE OF
SMTIH, JOHN, JAMES, P.R. OF THE ESTATE OF
SMITH, JOHN JAMES EST
EST OF JOHN SMITH
SMITH REAL ESTATE LLC
PRALINES";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}