import re
regex = re.compile(r"(^(THE\s)?((7)|ESTATE OF\s))?(.*?)(-?\s?DECEASED)?((P\.?R\.? OF THE)?(?(3)|\sESTATE OF))$", flags=re.MULTILINE)
test_str = ("SMITH JOHN ESTATE OF\n"
"SMITH JOHN J ESTATE OF\n"
"SMITH JOHN JAMES ESTATE OF\n\n"
"SMITH, JOHN ESTATE OF\n"
"SMITH, JOHN J ESTATE OF\n"
"SMITH, JOHN JAMES ESTATE OF\n\n"
"ESTATE OF JOHN SMITH - DECEASED\n"
"ESTATE OF JOHN J SMITH - DECEASED\n"
"ESTATE OF JOHN JAMES SMITH - DECEASED\n\n"
"SMITH, JOHN DECEASED ESTATE OF\n"
"SMITH, JOHN J DECEASED ESTATE OF\n"
"SMITH, JOHN JAMES DECEASED ESTATE OF\n\n"
"THE ESTATE OF JOHN SMITH\n"
"THE ESTATE OF JOHN J. SMITH\n"
"THE ESTATE OF JOHN JAMES SMITH\n"
"THE ESTATE OF JOHN J. SMITH, JR.\n"
"THE ESTATE OF JOHN SMITH DECEASED\n"
"THE ESTATE OF JOHN J. SMITH DECEASED\n"
"THE ESTATE OF JOHN JAMES SMITH DECEASED\n"
"THE ESTATE OF JOHN J. SMITH, JR. DECEASED\n\n"
"SMITH, JOHN, P.R. OF THE ESTATE OF\n"
"SMITH, JOHN, J, P.R. OF THE ESTATE OF\n"
"SMTIH, JOHN, JAMES, P.R. OF THE ESTATE OF\n\n"
"SMITH, JOHN JAMES EST\n"
"EST OF JOHN SMITH\n"
"SMITH REAL ESTATE LLC\n"
"PRALINES")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")