import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/[\\w-]*\\.?zoom.us\\/(j|my)\\/[\\d\\w?=-]+";
final String string = "https://yandex.zoom.us/my/somename\n"
+ "https://uni-hamburg.zoom.us/j/71047121108\n"
+ "https://zoom.us/j/9691388953?pwd=U2VnRTg5VDdzRW0xSHNlZXM4UFlKQT09\n"
+ "https://mvideoeldorado-ru.zoom.us/j/12317847439?pwd=UHM1bHdPZ2hPdmVrZlNtV2RMdXc5UT09\n"
+ "https://yandex.zoom.us/j/12303260396\n"
+ "https://us06web.zoom.us/j/12365249269?pwd=SFF3aTNyZ1dPSVRkcVN0aTV0SmxuQT09";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}