import Foundation
let pattern = #"https:\/\/[\w-]*\.?zoom.us\/(j|my)\/[\d\w?=-]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://yandex.zoom.us/my/somename
https://uni-hamburg.zoom.us/j/71047121108
https://zoom.us/j/9691388953?pwd=U2VnRTg5VDdzRW0xSHNlZXM4UFlKQT09
https://mvideoeldorado-ru.zoom.us/j/12317847439?pwd=UHM1bHdPZ2hPdmVrZlNtV2RMdXc5UT09
https://yandex.zoom.us/j/12303260396
https://us06web.zoom.us/j/12365249269?pwd=SFF3aTNyZ1dPSVRkcVN0aTV0SmxuQT09
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)