const regex = /https:\/\/[\w-]*\.?zoom.us\/(j|my)\/[\d\w?=-]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/[\\w-]*\\.?zoom.us\\\/(j|my)\\\/[\\d\\w?=-]+', 'g')
const str = `https://yandex.zoom.us/my/somename
https://uni-hamburg.zoom.us/j/71047121108
https://zoom.us/j/9691388953?pwd=U2VnRTg5VDdzRW0xSHNlZXM4UFlKQT09
https://mvideoeldorado-ru.zoom.us/j/12317847439?pwd=UHM1bHdPZ2hPdmVrZlNtV2RMdXc5UT09
https://yandex.zoom.us/j/12303260396
https://us06web.zoom.us/j/12365249269?pwd=SFF3aTNyZ1dPSVRkcVN0aTV0SmxuQT09`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}