$re = '/^art(?:\r?\n(?!art-|\s*code:"XXX").*)*\r?\n\s*code:"XXX"(?:\r?\n(?!art-).*)*\r?\nart-/m';
$str = 'begin
more text
art
id:213213
code:"XXX"
name:234
art-
art
id:543
name:72
code:"AAA"
art-
art
code:"XXX"
id:32
name:46
art-
art
code:"CCC"
id:8765
art-
art
id:876
code:"DDD"
art-
even more text
even more text
end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);