#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?y)\w+(-?\w+)*"
Local $sString = "asd" & @CRLF & _
"-" & @CRLF & _
"dsa-" & @CRLF & _
"-asd" & @CRLF & _
"asd-dsa" & @CRLF & _
"asd-dsa-das" & @CRLF & _
"asd-asd-asd-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")