$re = '/\w+(-?\w+)*/y';
$str = 'asd
-
dsa-
-asd
asd-dsa
asd-dsa-das
asd-asd-asd-';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);