const regex = /\w+(-?\w+)*/y;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(-?\\w+)*', 'y')
const str = `asd
-
dsa-
-asd
asd-dsa
asd-dsa-das
asd-asd-asd-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}