import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr>\\n\\s*<td width=\"70\"><strong>Released:<\\/strong><\\/td>\\n\\s*<td>(.*)<\\/td>\\n\\s*<\\/tr>\\n\\s*<tr>\\n\\s*<td width=\"70\"><strong>Runtime:<\\/strong><\\/td>\\n\\s*<td>(.*)<\\/td>\\n\\s*<\\/tr>\\n\\s*<tr>\\n\\s*<td width=\"70\"><strong>Genres:<\\/strong><\\/td>\\n\\s*<td><span class=\"movie_info_genres\"><a\\s[^<>]*>([^<>]*)<\\/a>";
final String string = "<tr>\n"
+ " <td width=\"70\"><strong>Released:</strong></td>\n"
+ " <td>July 25, 2014</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td width=\"70\"><strong>Runtime:</strong></td>\n"
+ " <td>90 mins </td>\n"
+ " </tr>\n"
+ " \n"
+ " <tr>\n"
+ " <td width=\"70\"><strong>Genres:</strong></td>\n"
+ " <td><span class=\"movie_info_genres\"><a href=\"/?genre=Action\">Action</a> <a href=\"/?genre=Sci-Fi\">Sci-Fi</a> </span></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td width=\"70\"><strong>Actors:</strong></td>\n"
+ " <td><span class=\"movie_info_actors\">\n"
+ " <a href=\"/?actor_name= Analeigh Tipton \"> Analeigh Tipton </a> <a href=\"/?actor_name= Morgan Freeman \"> Morgan Freeman </a> <a href=\"/?actor_name= Scarlett Johansson \"> Scarlett Johansson </a> <a href=\"/?actor_name=Min-sik Choi\">Min-sik Choi</a> </span></td>\n"
+ " </tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}