import Foundation
let pattern = #"<tr>\n\s*<td width="70"><strong>Released:<\/strong><\/td>\n\s*<td>(.*)<\/td>\n\s*<\/tr>\n\s*<tr>\n\s*<td width="70"><strong>Runtime:<\/strong><\/td>\n\s*<td>(.*)<\/td>\n\s*<\/tr>\n\s*<tr>\n\s*<td width="70"><strong>Genres:<\/strong><\/td>\n\s*<td><span class="movie_info_genres"><a\s[^<>]*>([^<>]*)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<tr>
<td width="70"><strong>Released:</strong></td>
<td>July 25, 2014</td>
</tr>
<tr>
<td width="70"><strong>Runtime:</strong></td>
<td>90 mins </td>
</tr>
<tr>
<td width="70"><strong>Genres:</strong></td>
<td><span class="movie_info_genres"><a href="/?genre=Action">Action</a> <a href="/?genre=Sci-Fi">Sci-Fi</a> </span></td>
</tr>
<tr>
<td width="70"><strong>Actors:</strong></td>
<td><span class="movie_info_actors">
<a href="/?actor_name= Analeigh Tipton "> Analeigh Tipton </a> <a href="/?actor_name= Morgan Freeman "> Morgan Freeman </a> <a href="/?actor_name= Scarlett Johansson "> Scarlett Johansson </a> <a href="/?actor_name=Min-sik Choi">Min-sik Choi</a> </span></td>
</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)