import re
regex = re.compile(r"<tr>\n\s*<td width=\"70\"><strong>Released:<\/strong><\/td>\n\s*<td>(.*)<\/td>\n\s*<\/tr>\n\s*<tr>\n\s*<td width=\"70\"><strong>Runtime:<\/strong><\/td>\n\s*<td>(.*)<\/td>\n\s*<\/tr>\n\s*<tr>\n\s*<td width=\"70\"><strong>Genres:<\/strong><\/td>\n\s*<td><span class=\"movie_info_genres\"><a\s[^<>]*>([^<>]*)<\/a>", flags=re.MULTILINE)
test_str = ("<tr>\n"
" <td width=\"70\"><strong>Released:</strong></td>\n"
" <td>July 25, 2014</td>\n"
" </tr>\n"
" <tr>\n"
" <td width=\"70\"><strong>Runtime:</strong></td>\n"
" <td>90 mins </td>\n"
" </tr>\n"
" \n"
" <tr>\n"
" <td width=\"70\"><strong>Genres:</strong></td>\n"
" <td><span class=\"movie_info_genres\"><a href=\"/?genre=Action\">Action</a> <a href=\"/?genre=Sci-Fi\">Sci-Fi</a> </span></td>\n"
" </tr>\n"
" <tr>\n"
" <td width=\"70\"><strong>Actors:</strong></td>\n"
" <td><span class=\"movie_info_actors\">\n"
" <a href=\"/?actor_name= Analeigh Tipton \"> Analeigh Tipton </a> <a href=\"/?actor_name= Morgan Freeman \"> Morgan Freeman </a> <a href=\"/?actor_name= Scarlett Johansson \"> Scarlett Johansson </a> <a href=\"/?actor_name=Min-sik Choi\">Min-sik Choi</a> </span></td>\n"
" </tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")