import re
regex = re.compile(r"<suburb>(.+?)<\/suburb>")
test_str = (" <primaryAddress>\n"
" <addressLine>280 Flinders Mall</addressLine>\n"
" <geoCodeGranularity>PROPERTY</geoCodeGranularity>\n"
" <latitude>-19.261365</latitude>\n"
" <longitude>146.815585</longitude>\n"
" <postcode>4810</postcode>\n"
" <state>QLD</state>\n"
" <suburb>Townsville</suburb>\n"
" <type>PHYSICAL</type>\n"
" </primaryAddress>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")