# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*(<!--.+?stylesheet.+?-->)"
test_str = ("<!-- The quick brown fox \n"
" jumps over the lazy dog -->\n\n"
"<!--[if IE 7]>\n"
" <link rel=\"stylesheet\" type=\"text/css\" href=\"/supersheet.css\" />\n"
"<![endif]-->\n\n"
"<!-- Pack my box with five dozen liquor jugs -->")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.