re = /^.*(<!--.+?stylesheet.+?-->)/
str = '<!-- The quick brown fox
jumps over the lazy dog -->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" href="/supersheet.css" />
<![endif]-->
<!-- Pack my box with five dozen liquor jugs -->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end