// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)^.*(<!--.+?stylesheet.+?-->)").unwrap();
let string = "<!-- The quick brown fox
jumps over the lazy dog -->
<!--[if IE 7]>
<link rel=\"stylesheet\" type=\"text/css\" href=\"/supersheet.css\" />
<![endif]-->
<!-- Pack my box with five dozen liquor jugs -->";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}