const regex = new RegExp('(\\\\begin\\{enumerate\\})(?=\\s\\\\end\\{enumerate\\}\\s\\s\\\\questao\\{\\d+\\})', 'g')
const str = `\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}