use strict;
my $str = '\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}';
my $regex = qr/(\\begin\{enumerate\})(?=\s\\end\{enumerate\}\s\s\\questao\{\d+\})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}