re = /(\\begin\{enumerate\})(?=\s\\end\{enumerate\}\s\s\\questao\{\d+\})/
str = '\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end