$re = '/(\\\\begin\{enumerate\})(?=\s\\\\end\{enumerate\}\s\s\\\\questao\{\d+\}$)/';
$str = '\\questao{1}
\\begin{enumerate}
\\end{enumerate}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
\\end{enumerate}
\\questao{2}
\\begin{enumerate}
fdafsafdsa
\\end{enumerate}
\\questao{2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);