import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=<input[^>]+(?=[\\s+class=\\\"]hashtag[\\s+\\\"]).+)([^>]+>)";
final String string = "<div class=\"hastag\"><div>\n"
+ "<input type=\"text\" value=\"#tag3\" notified=\"true\" class=\"label-primary hashtag\" zy-elastic-input=\"\" disabled=\"\" size=\"5\" style=\"text-align: center; line-height: 1em;\"> <input type=\"text\" value=\"Manolo Carro\" urn=\"zyncro:user:19b5b51b-e9fd-44d9-bfe1-9af0b171d6e6\" notified=\"true\" class=\"label-primary mention\" zy-elastic-input=\"\" disabled=\"\" size=\"12\" style=\"text-align: center; line-height: 1em;\"> <input type=\"text\" value=\"Carlos Galleta\" urn=\"zyncro:user:b3403527-7732-4e34-8fd6-bb0ae1b8eeda\" notified=\"true\" class=\"label-primary mention\" zy-elastic-input=\"\" disabled=\"\" size=\"14\" style=\"text-align: center; line-height: 1em;\"> asdf asdf dsf das<br>asdf asfadsfsaf adsf afs<br>asdf safasdfsdaf asdf<br>asdfadsf <sdfasf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}