import re
regex = re.compile(r"(?=<input[^>]+(?=[\s+class=\"]hashtag[\s+\"]).+)([^>]+>)", flags=re.IGNORECASE)
test_str = ("<div class=\"hastag\"><div>\n"
"<input type=\"text\" value=\"#tag3\" notified=\"true\" class=\"label-primary hashtag\" zy-elastic-input=\"\" disabled=\"\" size=\"5\" style=\"text-align: center; line-height: 1em;\"> <input type=\"text\" value=\"Manolo Carro\" urn=\"zyncro:user:19b5b51b-e9fd-44d9-bfe1-9af0b171d6e6\" notified=\"true\" class=\"label-primary mention\" zy-elastic-input=\"\" disabled=\"\" size=\"12\" style=\"text-align: center; line-height: 1em;\"> <input type=\"text\" value=\"Carlos Galleta\" urn=\"zyncro:user:b3403527-7732-4e34-8fd6-bb0ae1b8eeda\" notified=\"true\" class=\"label-primary mention\" zy-elastic-input=\"\" disabled=\"\" size=\"14\" style=\"text-align: center; line-height: 1em;\"> asdf asdf dsf das<br>asdf asfadsfsaf adsf afs<br>asdf safasdfsdaf asdf<br>asdfadsf <sdfasf\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")