use strict;
my $str = '<div class="hastag"><div>
<input type="text" value="#tag3" notified="true" class="label-primary hashtag" zy-elastic-input="" disabled="" size="5" style="text-align: center; line-height: 1em;"> <input type="text" value="Manolo Carro" urn="zyncro:user:19b5b51b-e9fd-44d9-bfe1-9af0b171d6e6" notified="true" class="label-primary mention" zy-elastic-input="" disabled="" size="12" style="text-align: center; line-height: 1em;"> <input type="text" value="Carlos Galleta" urn="zyncro:user:b3403527-7732-4e34-8fd6-bb0ae1b8eeda" notified="true" class="label-primary mention" zy-elastic-input="" disabled="" size="14" style="text-align: center; line-height: 1em;"> asdf asdf dsf das<br>asdf asfadsfsaf adsf afs<br>asdf safasdfsdaf asdf<br>asdfadsf <sdfasf
';
my $regex = qr/(?=<input[^>]+(?=[\s+class=\"]hashtag[\s+\"]).+)([^>]+>)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}