using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[[^][]*\])\s([^:]*):\s(.*)$";
string input = @"[00/0/00, 00:00:00] User: This is the message text and any other stuff
[00/0/00, 00:00:00] User: This is the message text : and any other stuff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}