$re = '/(\[[^][]*\])\s([^:]*):\s(.*)$/m';
$str = '[00/0/00, 00:00:00] User: This is the message text and any other stuff
[00/0/00, 00:00:00] User: This is the message text : and any other stuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);