re = /(\[[^][]*\])\s([^:]*):\s(.*)$/m
str = '[00/0/00, 00:00:00] User: This is the message text and any other stuff
[00/0/00, 00:00:00] User: This is the message text : and any other stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end