import re
regex = re.compile(r"[a-z.]+$")
test_str = ("/10e0036e1k_GfeV_33_VW_30_a.pdf\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")