const regex = /(ADDITIONAL.*?Languages)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ADDITIONAL.*?Languages)', '')
const str = `str = "the companys direction ADDITIONAL Awards: 2010 Global Engagement Summit, Languages: Fluent Japanese"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}